BizTalk 2009 on Visual Studio 2010 Beta 2

 
If you saw my posts a few months ago, I was testing BizTalk 2009 compatibility with VS 2010. My earlier posts found that the BizTalk extensions would only load in VS 2008 and not in VS 2010. In this post, I do a refresh of the install experience and give some preview of the .NET 4 features showing up in BizTalk 2009. The same conclusion about compatibility is reached here: the BizTalk 2009 extensions do not work with VS 2010. There is a new workarounds for getting a VS 2008/VS 2010 environment for working with BizTalk 2009.
 
Application Install Order
 
  • Use a clean VPC image
  • Setup pre-requisites: W2K8, SQL 2008
  • Install VS 2010 Beta 2
  • Install VS 2008, and VS 2008 SP1
  • Install BizTalk 2009

BizTalk Configuration

Then when configuring BizTalk on the first step for Enterprise Single Sign-On I get an error similar to this (cannot remember exact wording sorry):
 
Cannot connect to SSODB (Win32)
0x80131700
 
I found this blog post about re-regasm-ing the SSOSQL assembly: http://blogs.msdn.com/ashishme/archive/2009/08/14/fixing-biztalk-entsso-failure-on-windows-7-vista-or-server-2008-after-vs-2010-beta-installation.aspx#comments. This helped me get around the error when configuring SSO. It is interesting that the problem occurs when VS 2010 is install prior to or after BizTalk 2009. I was then able to go through the BizTalk configuration wizard successfully. I was able to create BizTalk projects in VS 2008 fine. I did open the VS 2010 extensions manager and check for the BizTalk extensions but they are not showing up there.
 
There are quite a few valuable improvements with WCF 4 such as WS Discovery support, routing, and additional changes to Windows Workflow. All of these will have an impact on the Connected System landscape. Enjoy!
 
Advertisements

, ,

  1. #1 by Ben on November 4, 2009 - 10:41 pm

    I am thinking the SSO issue must have come up during Beta 1 – there are a couple people out there who have reported the regasm workaround during the summer months. Its funny the issue never happened to me during the CTPs of VS 2010.

  2. #2 by Mark on November 5, 2009 - 2:08 am

    I had that exact same SSOSQL.dll error today with 2006R2, though I had to run the regasm command through the x64 version. I was suprised. Thank you for keeping us up to date with the 2009/2010 compatibility updates.

  3. #3 by Ben on November 5, 2009 - 4:39 pm

    Mark, that’s interesting the problem occurred on 2006 R2. Did you have VS 2008 on the box or just VS 2005? Thanks!

  4. #4 by Mark on January 20, 2010 - 4:23 am

    I think I had 2005, 2008 SP1 and 2010 beta.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: